
Map Bits as Fill Styles
A Campaign Cartographer 3 Tutorial

by Joachim de Ravenbel1

Conventions

Throughout this tutorial, I will use a color coding to clearly identify all the keywords:
Sheet names will always appear in Green,
Keyboard commands or keys will always appear in Red,
CC3 menu commands will always appear in Italic Orange.
A bold Black name followed by an arrow pointing right → and, at least at the end, an Italic

Orange  name indicates  a  CC3 menu drop-down list  leading to  a  command.  Black  names also
represent buttons or sheet effects.

Introduction

CC3 is loaded with awesome sheet effects. If you want to use a lot of effects, you usually end up with
a lot of sheets and a very high render time.  By creating some parts in a sub CC3 file using the
method described here, you will have the benefit of a lot of effects without the drawbacks.

On the above sample map, the circular hole has been exported from a sub-map and the export file
used to create a new fill style.

1 Many thanks to Terraformer Author, for creating and sharing the nice font used for the title. You can find it here.
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Planning

The method comes with a price too: you need to work on two different scales: CC3 units and pixel
units. You also need to choose the size of the final version export.

The  nature  of  CC3  units,  whether  feet,  miles,  meters  or  kilometers  is  not relevant.  CC3  units
correspond to the “real” dimensions of the map's entities.  What  is important is knowing how many
pixels you want to represent the scope of the map. A pixel is a small colored square. A digital picture
is made by placing millions of these square in the picture's area. A pixel is also the “dot” in “dot per
inch” or “dpi” resolution. A value of 150 dpi means that for a length of 1 inch, your printer will align 150
colored squares. For example a 10'×10' at a resolution of 300 dpi will have 3000×3000 pixels on it.

The important difference between CC3 units and pixels is that when dealing with CC3 units, decimal
numbers  are  allowed and very frequent  indeed.  Pixels  are  always  numbered in  whole  numbers
(integers).

There is thus three unit systems to consider:
1. CC3 units: “real” dimensions
2. Pixels numbers: whole numbers counting the number of colored “dots” of a digital picture.
3. Paper units if you want to print the map. If you just wish to create the map for a digital display,

you usually know the pixels numbers and don't need to consider this third system.

These three systems work together because they all correspond to the same map. The conversion is
not too hard: you have to multiply or divide a number from one system by a scale factor to get the
equivalent in another system. The next steps are about finding the  factor between CC3 units and
pixels:

1. Determine the scope of your map in CC3 units. This is usually decided when you start the map
using a template. However, you sometimes find that the initial size is not enough and enlarge
the map. If you don't know the extents of your map, use the  Info→Distance tool (F8) and
select opposite corners of the map border using the Endpoint modifier  (F5). The sample
map is 200'×200'.

2. Determine the size in pixels of the final product. If you want a paper print multiply the desired
size in inches or centimeters by the chosen print resolution in dpi if the size is in inches, in
ppcm (pixels per centimeter) if it's in centimeters. If you want a digital picture, just define the
number of pixels compatible with the use of the map.  The sample map was exported as a
3000×3000 pixels png file.

3. Determine the factor between CC3 units and pixels number by dividing the length of the map
in pixels by the length of the map in CC3 units.  For the sample map, the CC3 units  size is
200'×200' whereas the final output will be at 3000×3000 pixels. The factors between CC3 units
and pixels numbers is thus 3000÷200 = 15:

Size in CC3 units ×15 → size in pixels
            Size in pixels ÷ 15 → size in CC3 units

In some cases, the result might not be a whole number.  You can round the result but the more
precise way is to keep it as a fraction. For example if you have a 300'×300' CC3 units map you want

to export to a 2000×2000 pixels picture, the factor is 2000÷300=
20
3

≃6,66667 .

Size in CC3 units ×20 → ÷ 3 → size in pixels
               Size in pixels × 3 → ÷20 → size in CC3 units
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It is important that the inserts resolution is not lower than the final export or the transition between
them will be too obvious.

The main map

The work starts with the main map and the inserts are created when needed. The sample map shown
here has been created using the steps detailed in the Chapel Tutorial (if you're interested, the floor fill
style can be found here). An empty circular area sits in the center, open to a level below:

This low level features pools lighted by glowing crystals. The main floor will also be lighted but these
lights should not affect the lower level. By carefully adding sheets and effects you might achieve a
satisfying result. The solution presented here reduces the number of sheets and thus allows faster
rendering and exports. The steps that will need to be taken are:

1. Create a sub-map in CC3
2. Measure the size of the circular “hole” on the main map
3. Export a rectangular section png picture of the required size at the required resolution
4. Create a fill style on the main map file using the sub-map export
5. Draw a circle on the main map file with the new fill style.
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1. Create a sub-map in CC3

This sub-map is created similarly to the main map:

       
Left: effects off,  right: effects on. The rings and pools sides are all  very low walls that cast  short
shadows.

2. Measure the size of the circular “hole” on the main map

Use the Info→Distance (or the function key F8) and click on the hole's center (hopefully it's a grid
node easy to select with the  Snap button down, alternatively  click the  center modifier F4 then
click on the circle to get its center precisely) then on a point on the circular rim.
The sample map gives a distance of 19.96247. Rounding is necessary because the export will need
a size in pixels by whole numbers (also called integers). Usually you need to round to the nearest
upper value to be sure to cover all the target area. Here it will be 20' for the radius, meaning a 40'
diameter.
Because in the planning section (page 2) you defined the factor between CC3 units and pixels (15
for the sample map), you can now compute the export size needed: 40'×15=600  pixels wide.

3. Export a rectangular section png picture of the required size at the required resolution

When exporting a rectangular (or here square) part of a map with precision, you need a way to pick
the opposed corner of the rectangle. One possibility is to use the coordinates of these corners. 
Even if you didn't use the grid snapping, you can still change the coordinates system on the sub-map
using the View→ Move Origin command (or the keyboard command ORIGIN followed by a carriage
return). The cross-hair cursor appears to select the new origin so pick it with the center modifier 
F4.
Now you  know that  the  lower  left  corner's  coordinates  are  -20,-20  and the  upper  right  corner's
coordinates are 20,20 (if necessary adapt these numbers to the size found in step 2. above).
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• Make sure the effects are on.  Otherwise click on the Sheet Indicator, check Activate Sheet
Effects and click OK.

• Use the File→Save as command (keyboard EXPORT). A pop-up appears. 
• Click  on  the  “v”  button  at  the  right  end  of  the  Type line  (commonly  showing  “Campaign

Cartographer 3 FCW drawing”) and select Rectangular section PNG in the drop-down list. 
• Click on the Options button to launch a new pop-up.
• Set  the  Width  and  Height to  the  target  values  in  pixels  plus  one (for  the  sample  map

601×601): you have perhaps already noticed that CC3 adds a pixel on the top and right sides
of the export, probably due to the conversion of a continuous length unit to a discrete (whole)
number of pixels. To circumvent this habit, you need to add one to all the pixel sizes (and to
remove the extra pixels afterward).

• Click OK to close the second pop-up. 
• Change the file name if you wish, note the location of the export (usually the same folder as

the map but you may change it) and click Save to launch the export. 
• The prompt reads “Pick first corner” in the command line. Just type  -20,-20 (adapt values if

necessary) and hit return. The prompt now reads “Opposite corner” so type 20,20. CC3 starts
to export the map and you can follow the progress on the status bar turned red on the top left
of your CC3 window.

• Once CC3 finishes exporting, open an image editor (such as
PhotoFiltre, the Gimp or Photoshop) and crop the picture file to
600x600. You need to remove a single pixel line at the top and
a single pixel column at the left so  make sure you keep the
lower right part of the picture. Save the modified file.
→ With PhotoFiltre, the way to do this is to  Image→Canvas
Size, reduce the Width and Height by 1 and click in the lower
right square in the 3×3 grid.
→ With The Gimp, also use Image→Canvas Size click on the
chain  picture  to  enable  disproportional  resizing,  reduce  the
Width and the Height by one and set both offsets at -1. 
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4. Create a fill style on the main map file using the sub-map export

• Open the main map and click on the Fill Style Indicator (A rectangle top right beginning with
FS). Select the Bitmap Files Tab.

• Click on New and type a name such as “HOLE” for example.
• Click on Find and browse the png file saved at step 3.
• Check the Scaled check box and set the width and height to the size found at step 2, in CC3

units (for the sample map, 40 and 40).  You can also set the  Sample Width to the greatest
value of the width or size.

• Verify that the Tile to fill, Opaque and This is the current fill style radio buttons are on, and
that Outlined is unchecked.

Note: if you uncheck Scaled and choose Expand to fit or Stretch to fill you'll get the same result as
the png size is indeed made to fit the circle.
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5 Draw a circle on the main map file with the new fill style.

Because the new fill  style is now the current fill  style you just need to draw a circle fill  the hole,
preferentially on a new sheet:

• Click on the Sheet Indicator than on the right Add button. Type the name of the new sheet (eg.
HOLE) and click on the Move Up button to place the sheet under (in the list, above, the order
is reversed compared to the graphic output) the FLOOR sheet. Click OK to close the sheets
list.

• Launch the Circle tool  (CIRP), use the center modifier  (F4) to select the center (or if
this center is conveniently a grid node, just make sure the Snap button is down and click on
the center) than type @20,0 (adapt to your map, 20 is the radius of the circle) followed by a
carriage return (the “@” character means “coordinates relative to the last selected point”):
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About fill styles

If you read the Chapel tutorial, you are already aware that fill styles fill from the upper left corner of
the  smallest  horizontal  rectangle
bounding  the  shape  to  fill.  Consider
the following circles:

The first circle has a radius of 20', the
second of 25' and the third of 15'. The
fill style is not applied from the center
but  from the blue  dot:  the  upper  left
corner  of  the  dotted  red  bounding
rectangle.

Adding an effect

The main technique detailed above is used to reduce effects in the main map but you can still add
effects to the sheet receiving the fill style. For example, to simulate the depth of the low level on the
sample map, a simple GLOW effect has been added:

• Click on the Sheet Indicator and select the HOLE sheet by clicking on its name: the line should
turn gray (if it's already gray, proceed to next step).

• Check Activate Sheet Effects and click on the Add button on the right side of the pop-up (the
left one adds a sheet as described page 5).  

• Select  Glow in the new pop up then set the parameters  on the third pop-up:  Inside radio
button on, Strength 1 and Blur radius 10. Click OK to close the last pop-up than OK to close
the sheets list.

Note: prior to adding the effect, the shape could very well have been a square as everything outside
the circle is hidden by the floor multipoly. With a square shape, most of the Glow effect would have
been hidden too...
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Conclusion
In this tutorial we followed 5 steps to take a drawing with effects in a sub map, converted it into an
accurate sized fill style, and incorporated the new fill style into a different, main map. This method
provides a CC3 user even greater flexibility with the use of multiple effects and improves system
performance.

Any picture file can be used as a fill style (provided it is in png or bmp file format) and not every fill
style needs to be tiling (repeating copies of the original picture).  However, due to the fact that fill
styles are applied from the top left corner of the bounding rectangle, you need to carefully determine
the resolution and size of the picture files you export from CC3.

The drawback is that if you ever want a larger resolution, you'll need to create again all the map bits
in the higher resolution.

Happy mapping!
Joachim de Ravenbel

June 2013
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